Add a curve to the GRep associated to this ViewShapeBuilder.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- GCurve
- Type: Autodesk.Revit.DBCurve
The curve to be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | GCurve is not acceptable for view-specific shape representation that is currently being built. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |