IsValidValue Method


Checks that the value is a valid value for this property.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018.1

Syntax

C#
public bool IsValidValue(
	float value
)
Visual Basic
Public Function IsValidValue ( _
	value As Single _
) As Boolean
Visual C++
public:
bool IsValidValue(
	float value
)

Parameters

value
Type: SystemSingle
The value to be checked.

Return Value

True if the value is valid for the property.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException Cannot check validity for a property not being edited in AppearanceAssetEditScope.

See Also