ElementId Property


The element id where this analytical segment belongs.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public ElementId ElementId { get; set; }
Visual Basic
Public Property ElementId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ ElementId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException When setting this property: A non-optional argument was null

See Also