ConvertSymbolicToModelCurves Method


Converts a group of SymbolicCurves to equivalent ModelCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelCurveArray ConvertSymbolicToModelCurves(
	View view,
	SymbolicCurveArray symbolicCurve
)
Visual Basic
Public Function ConvertSymbolicToModelCurves ( _
	view As View, _
	symbolicCurve As SymbolicCurveArray _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ ConvertSymbolicToModelCurves(
	View^ view, 
	SymbolicCurveArray^ symbolicCurve
)

Parameters

view
Type: Autodesk.Revit.DBView
The view where the new lines will be created. The lines are projected on the view workplane. The view workplane must be parallel to the view plane.
symbolicCurve
Type: Autodesk.Revit.DBSymbolicCurveArray
The symbolic curve array to be converted.

Remarks

This operation will create new ModelCurves with the symbolicCurves' geometry curves and delete the SymbolicCurve in the array.

Exceptions

ExceptionCondition
SystemArgumentNullException Thrown when the input argument is a null reference (Nothing in Visual Basic).
SystemInvalidOperationException Thrown when one or more curves could not be successfully converted.

See Also