RemoveHostConstraint Method


Removes constraint from host for this load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void RemoveHostConstraint()
Visual Basic
Public Sub RemoveHostConstraint
Visual C++
public:
void RemoveHostConstraint()

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException This LoadBase is not a constraint load.
Autodesk.Revit.Exceptions ModificationForbiddenException Thrown when the load is an AreaLoad and the host is an Analytical Panel with curved profile.

See Also