Get the total building volume represented by a mass instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The Document.
- massInstanceId
- Type: Autodesk.Revit.DBElementId
The ElementId of the mass instance.
Return Value
The gross volume in cubic feet.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The ElementId massInstanceId is not a mass instance. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |