Views Property


The views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ViewSet Views { get; set; }
Visual Basic
Public Overridable Property Views As ViewSet
	Get
	Set
Visual C++
public:
virtual property ViewSet^ Views {
	ViewSet^ get ();
	void set (ViewSet^ value);
}

Implements

IViewSheetSetViews

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the input views is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the set operation failed due to invalid view which cannot be printed.

See Also