ElementMulticategoryFilter Constructor (ICollection(ElementId))


Constructs a new instance of a filter to find elements whose category matches any of a given set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public ElementMulticategoryFilter(
	ICollection<ElementId> categoryIds
)
Visual Basic
Public Sub New ( _
	categoryIds As ICollection(Of ElementId) _
)
Visual C++
public:
ElementMulticategoryFilter(
	ICollection<ElementId^>^ categoryIds
)

Parameters

categoryIds
Type: System.Collections.GenericICollectionElementId
The category ids to match.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException One or more categories was not valid for filtering.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also