Connects placeholders that looks like elbow connection.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- placeholder1Id
- Type: Autodesk.Revit.DBElementId
The element Id of pipe placeholder.
- placeholder2Id
- Type: Autodesk.Revit.DBElementId
The element Id of pipe placeholder.
Return Value
True if connection succeeds, false otherwise.Remarks
There must be a physical end connection of placeholders. If connection fails, the placeholders cannot be physically connected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The element id placeholder1Id is not pipe placeholder. -or- The element id placeholder2Id is not pipe placeholder. -or- The elements belong to different types of system. -or- The curve placeholder1Id and placeholder2Id are not physically connected. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |