Gets the default view name that will be used when creating a regular schedule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document to which the new schedule will be added.
- categoryId
- Type: Autodesk.Revit.DBElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.
Return Value
The default view name.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- The Areas category was specified but an area scheme ID was not provided. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |