MajorSegmentIndex Property


Index of a segment that can be considered the most important. Revit attempts to preserve the orientation of this segment when a Rebar instance changes its RebarShape to one with a different number of segments.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public int MajorSegmentIndex { get; set; }
Visual Basic
Public Property MajorSegmentIndex As Integer
	Get
	Set
Visual C++
public:
property int MajorSegmentIndex {
	int get ();
	void set (int value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: majorSegmentIndex is not between 0 and NumberOfSegments.

See Also