Create a MassLevelData (Mass Floor) to associate a Level with a mass instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The Document.
- massInstanceId
- Type: Autodesk.Revit.DBElementId
The ElementId of the mass instance.
- levelId
- Type: Autodesk.Revit.DBElementId
The ElementId of the Level to associate with the mass instance.
Return Value
The ElementId of the MassLevelData that was created, or the existing ElementId if it was already in added.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The ElementId massInstanceId is not a mass instance. -or- The ElementId levelId is not a Level. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |