SketchGalleryOptions Property


The sketch option provided when promt to place a family instance.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public SketchGalleryOptions SketchGalleryOptions { get; set; }
Visual Basic
Public Property SketchGalleryOptions As SketchGalleryOptions
	Get
	Set
Visual C++
public:
property SketchGalleryOptions SketchGalleryOptions {
	SketchGalleryOptions get ();
	void set (SketchGalleryOptions value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also