TemperatureRatingType Class


Represents temperature rating type definition information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class TemperatureRatingType : ElementType
Visual Basic
Public Class TemperatureRatingType _
	Inherits ElementType
Visual C++
public ref class TemperatureRatingType : public ElementType

Remarks

Temperature rating type is defined based on corresponding wire material type. It includes type information such as wire size, insulation type, correction factor, etc. Only the temperature rating types which are retrieved from WireMaterialType can work well, so don't retrieve it from Revit document directly.

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DB.ElectricalTemperatureRatingType

See Also