AddConstraintSagittaLength Method


Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2009

Syntax

C#
public void AddConstraintSagittaLength(
	ElementId paramId
)
Visual Basic
Public Sub AddConstraintSagittaLength ( _
	paramId As ElementId _
)
Visual C++
public:
void AddConstraintSagittaLength(
	ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DBElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().

Remarks

The sagitta will be measured on the centerline of the bar.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also