SelectPanel Method


Electrical System Select Panel Method

Set the panel for the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SelectPanel(
	FamilyInstance panel
)

Parameters

panel FamilyInstance
The panel of the electrical system.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The panel does not have enough slots and Feed Through Lugs is unchecked or already in use. -or- Thrown when the panel cannot be set for the electrical system.
Remarks
If successful, the panel will be set for the system. Otherwise the exception will be thrown. This method will only function with the Autodesk Revit MEP application.
See Also