AddModule Method


Macro Manager Add Module Method

Adds a MacroModule to the application.

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPIMacros (in RevitAPIMacros.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public MacroModule AddModule(
	ModuleSettings moduleSettings,
	IModuleMaker maker
)

Parameters

moduleSettings ModuleSettings
The module settings.
maker IModuleMaker
The interface to create module project.

Return Value

MacroModule
The new module.
Exceptions
Exception Condition
ArgumentException Thrown when the module name is duplicated with the existing one, or the name is too long, or the name contains invalid identifier(s), such as include "#", "%", ... and key words in C#.
ArgumentNullException A non-optional argument was null
See Also