ExtraCheckBoxText Property


Task Dialog Extra Check Box Text Property

ExtraCheckBoxText is used to label the extra checkbox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string ExtraCheckBoxText { get; set; }

Property Value

String
Exceptions
Exception Condition
InvalidOperationException Thrown if the TaskDialog also has EnableMarqueeProgressBar set as the two cannot coincide in the same TaskDialog.
Remarks
If ExtraCheckBoxText is set, a checkbox with the text will be shown. You can get the response of checkbox by checking the return value of the WasExtraCheckBoxChecked() method.
See Also