ContourSettingItem Class


Contour Setting Item Class

Contour setting item that stores the information of a single contour or a set of contours.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ContourSettingItem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ContourSettingItem : IDisposable

The ContourSettingItem type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Start The contour range start elevation.
Public property Step The increment elevation of the contour range.
Public property Stop The contour range stop elevation.
Public property SubCategoryId The contour line style subcategory id.
Public property Type The contour setting item type.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ContourSettingItem
Top
See Also