Rebar |
Identifies if the stagger length is auto calculated for the specified Rebar Splice Type.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- rebarSpliceTypeId ElementId
- The Rebar Splice Type id. Interactions with Rebar Splice Types can be done with the functions in RebarSpliceTypeUtils .
Return Value
BooleanReturns true if the stagger length is auto calculated for the specified rebar bar type and Rebar Splice Type, false otherwise.

Exception | Condition |
---|---|
ArgumentException | The rebarSpliceTypeId doesn't represent a valid Rebar Splice Type. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category. |
ArgumentNullException | A non-optional argument was null |

If it is auto calculated, stagger length value is computed based on the formula: stagger length multiplier (found in splice type) * lap length.