DimensionEqualityLabelFormatting Class


Dimension Equality Label Formatting Class

Instances of this class represent individual parameters used to make up a dimension equality formula for continuous linear or angular dimensions.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB DimensionEqualityLabelFormatting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DimensionEqualityLabelFormatting : IDisposable

The DimensionEqualityLabelFormatting type exposes the following members.

Constructors
Name Description
Public method DimensionEqualityLabelFormatting Constructs a new instance of a DimensionEqualityLabelFormatting object with specified settings.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LabelType The parameter value to be shown.
Public property LeadingSpaces The number of spaces to include before the parameter value.
Public property Prefix The prefix to include before the parameter value.
Public property Suffix The suffix to include after the parameter value.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the DimensionEqualityLabelFormatting
Public method GetFormatOptions Gets the format options used to show the parameter value.
Public method IsValidFormatOptions Checks whether a FormatOptions object is valid for the LabelType.
Public method SetFormatOptions Sets the format options used to show the parameter value.
Top
See Also