Export Method (String, String, ViewSet, FBXExportOptions)


Document Export(String, String, View Set, FBXExport Options) Method

Exports the document in 3D-Studio Max (FBX) format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Export(
	string folder,
	string name,
	ViewSet views,
	FBXExportOptions options
)

Parameters

folder String
Output folder, into which file(s) will be exported. The folder must exist.
name String
Either the name of a single file or a prefix for a set of files. If or empty, automatic naming will be used.
views ViewSet
Selection of views to be exported.Only 3D views are allowed.
options FBXExportOptions
Options applicable to the FBX format.

Return Value

Boolean
Function returns true only if all specified views are exported successfully. The function returns False if exporting of any view fails, even if some views might have been exported successfully.
Exceptions
Exception Condition
ArgumentNullException Thrown when the input views is
ArgumentException Thrown when the input views is an empty ViewSet. Thrown if any view in the views is not a 3D view.
Remarks
Though the 'options' argument is not currently used, an object still must be provided (may be ).
See Also