Family |
Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- reference Reference
- The family instance reference.
Return Value
FamilyInstanceReferenceTypeReturns the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference. Returns FamilyInstanceReferenceType.NotAReference if the instance reference doesn't correspond to a reference plane or line in the family.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |