ExternalService Class


External Service Class

This base class represents an external service inside Revit application.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalService : IDisposable

The ExternalService type exposes the following members.

Properties
Name Description
Public property Description The description for the service
Public property IsSerializable Indicates whether executions of the service requires serialization in documents or not.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The name of the service
Public property NumberOfServers Indicates the number of servers currently registered with the service.
Public property ServiceId The Id of the service
Public property SupportActivation Indicates if the service supports activation/deactivation of the servers.
Public property VendorId The vendor who provided the service
Top
Methods
Name Description
Public method AddServer Registers a server with its service.
Public method Dispose Releases all resources used by the ExternalService
Public method GetDefaultServerId Returns the Id of the default server if one was assigned to the service.
Public method GetOptions A copy of the options the service was registered with.
Public method GetPublicAccessKey Access key to use to execute a service.
Public method GetRegisteredServerIds Returns Ids of all servers registered for the service.
Public method GetServer Returns the instance that provides implementation for a registered server.
Public method IsRegisteredServerId Checks if the Id represents a valid server that has been registered for the service.
Public method RemoveServer Removes/unregisters a server from the service.
Top
Remarks

This is a base class from which SingleServerService and MultiServerService classes are inherited. It implements all basic methods, but the two inherited classes add more methods specific for that kind of service the class represents. Use this base class to get information about a service and its servers. Use the specific inherited classes to set or get active servers.

Summary of common methods:
  • Adding and removing a server to and from a service
  • Getting information about a service
  • Querying a number of servers registered for a service
  • Accessing servers currently registered for a service
Summary of the service-specific methods:
  • Getting and setting active server (or servers) for a service
See Also