Piping |
Creates a new instance of a piping system type and adds it to the document.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static PipingSystemType Create(
Document ADoc,
MEPSystemClassification systemClassification,
string name
)
Parameters
- ADoc Document
- The document where the element will be created and added.
- systemClassification MEPSystemClassification
- The classification for the piping system type to be created
- name String
- The name of the piping system type to be created.
Return Value
PipingSystemTypeThe newly created piping system type element.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
ArgumentsInconsistentException | The system classification is not valid for the domain of this system type. |