GetRibbonPanels Method (String)


UIApplication Get Ribbon Panels(String) Method

Get all the custom Panels on a designated Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual List<RibbonPanel> GetRibbonPanels(
	string tabName
)

Parameters

tabName String
The name of the tab on which the panels are located.

Return Value

List RibbonPanel
Remarks
Built-in panels will not be included. tabName must be the name of one of the tabs added by CreateRibbonTab(String) . This method is not supported in Macros.
See Also