NewOpening Method (Wall, XYZ, XYZ)


Document New Opening(Wall, XYZ, XYZ) Method

Creates a rectangular opening on a wall.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Opening NewOpening(
	Wall wall,
	XYZ pntStart,
	XYZ pntEnd
)

Parameters

wall Wall
Host element of the opening.
pntStart XYZ
One corner of the rectangle.
pntEnd XYZ
The opposite corner of the rectangle.

Return Value

Opening
If successful, an Opening object is returned.
Exceptions
Exception Condition
ArgumentException Thrown if the wall does not exist in the given document, or if the wall doesn't support rectangular openings.
Remarks
Slanted stacked walls do not support rectangular openings.
See Also