Create Method


Duct Lining Create Method

Creates a new instance of duct lining.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static DuctLining Create(
	Document document,
	ElementId ductOrContentElementId,
	ElementId ductLiningTypeId,
	double Thickness
)

Parameters

document Document
The document.
ductOrContentElementId ElementId
The duct, fitting or accessory ElementId to which lining will be added.
ductLiningTypeId ElementId
The duct lining type. If the input duct lining type is InvalidElementId, the default lining type from the document will be used.
Thickness Double
The thickness of the lining.

Return Value

DuctLining
The newly created duct lining.
Exceptions
Exception Condition
ArgumentException This id does not represent a duct, fitting, or accessory element. -or- This duct Lining type is invalid. -or- Thickness is not valid for assignment to insulation or lining elements.
ArgumentNullException A non-optional argument was null
InvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also