FilterDialog Constructor (Document, String)


Filter Dialog(Document, String) Constructor

Constructs a new instance of the FilterDialog class, while setting the name of the new ParameterFilterElement to be created and selected for editing.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FilterDialog(
	Document doc,
	string name
)

Parameters

doc Document
The document that owns the FilterElements displayed and edited in the dialog.
name String
The user-visible name for the new ParameterFilterElement.
Exceptions
Exception Condition
ArgumentException name is an empty string. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a filter element name.
ArgumentNullException A non-optional argument was null
Remarks
Show the dialog with the Show() method after setting the desired options.
See Also