RebarHandleType Enumeration


Rebar Handle Type Enumeration

The various types of handles on a Rebar instance that can be joined to References

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum RebarHandleType
Members
Member name Value Description
CustomHandle 5 Custom handle used in API constraints. The handle itself and the behavior of this type of handle is defined in the API (see IRebarUpdateServer ). This handle defines a symbolic part of the rebar and is not tied to a specific segment or part of the rebar. Handles that represent the start and end of a bar should not be of this type.
Edge 3 Handle controlling location of a single edge segment of the Rebar. Drives the edge in the direction perpendicular to the edge and in the Rebar's primary plane.
EndOfBar 2 Handle controlling end point of the Rebar.
OutOfPlaneExtent 4 Handle controlling the extent of a three-dimensional Rebar out of its primary plane. This includes the length of a Rebar Set, the out-of-plane length of a multi-planar Rebar, and the length of a spiral Rebar.
RebarPlane 0 Handle controlling the location of the Rebar's primary plane. Drives location of the entire Rebar along the direction of its normal.
StartOfBar 1 Handle controlling start point of the Rebar.
Undefined -1 Represents an undefined handle. If this value is returned, then the handle cannot find its type.
See Also