GetChangedElements Method


Document Get Changed Elements Method

Extracts a collection containing the ids of elements that have been created, modified or deleted between the input baseVersion and the document's current version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public DocumentDifference GetChangedElements(
	Guid baseVersionGUID
)

Parameters

baseVersionGUID Guid
GUID of base version(excluded) to compare. This GUID should be retrieved from property [!:Autodesk::Revit::DB::DocumentVersion::VersoinGUID] . Empty GUID is allowed to retrieve changes of each version in the document.

Return Value

DocumentDifference
An object containing collections of the created, modified and deleted ids between the input version and current version.
Exceptions
Exception Condition
ArgumentException This GUID is invalid in the given document.
See Also