Direct |
Gets override settings associated with a DirectContext3D handle instance or type.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public DirectContext3DHandleSettings GetDirectContext3DHandleSettings(
Document aDoc,
ElementId elementId
)
Parameters
Return Value
DirectContext3DHandleSettingsThe override settings assigned to the handle element, if present, or a default override settings if nothing was found.

Exception | Condition |
---|---|
ArgumentException | The ElementId elementId is not a valid DirectContext3D handle instance or type. |
ArgumentNullException | A non-optional argument was null |