Temporary |
The context data that can be provided to OnClick(TemporaryGraphicsCommandData) .

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The TemporaryGraphicsCommandData type exposes the following members.

Name | Description | |
---|---|---|
![]() | Document | The document. |
![]() | Index | The unique index of the temporary graphics object managed by TemporaryGraphicsManager . |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the TemporaryGraphicsCommandData |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |