Rebar |
Identifies the hook offset length for a hook type
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- hookId ElementId
- id of the hook type
Return Value
DoubleThe hook offset length for a hook type

Exception | Condition |
---|---|
ArgumentException | the rebar hook type id hookId is not valid -or- the hook specified by id hookId doesn't have valid offset length -or- The element hookId does not exist in the document containing this RebarBarType -or- the hook specified by id hookId doesn't have valid default offset length |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The document containing this RebarBarType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The element is a member of a loaded family. -or- The element is a member of a group type that is not being edited. -or- hookId is a member of a loaded family. -or- hookId is a member of a group type that is not being edited. |

If the AutoCalcHookLengths property is turned off, the default hook offset length will be returned