Field Class


Field Class

The description of a field within a Schema in the Extensible Storage framework. Contains the field's name, type, access control and documentation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.ExtensibleStorage Field

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Field : IDisposable

The Field type exposes the following members.

Properties
Name Description
Public property ContainerType Reports whether this is a simple field containing one value, or a container of multiple values.
Public property Documentation The overall description of the Field.
Public property FieldName The name of the field.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property KeyType The type of the keys stored in the field.
Public property Schema The Schema to which this Field belongs.
Public property SubSchema The Schema describing the subentity (or subentities) stored in this Field.
Public property SubSchemaGUID The GUID of the Schema describing the subentity (or subentities) stored in this Field.
Public property ValueType The type of the values stored in the field.
Top
Methods
Name Description
Public method CompatibleUnit Checks if the specified unit is compatible with the field description.
Public method Dispose Releases all resources used by the Field
Public method GetSpecTypeId Gets the spec describing the values stored in this field.
Public method SubEntityReadAccessGranted Checks whether there is read access to subentities storable in this field.
Public method SubEntityWriteAccessGranted Checks whether there is write access to subentities storable in this field.
Top
See Also