Filtered |
Returns an element id iterator to the elements passing the filters.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

Return Value
FilteredElementIdIterator
Exception | Condition |
---|---|
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter. |

Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.