Light |
Creates a light type object from the given document and element ID
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

public static LightType GetLightTypeFromInstance(
Document document,
ElementId instanceId
)
Parameters
- document Document
- The document the instanceId is from
- instanceId ElementId
- The ID of the light fixture instance
Return Value
LightTypeThe newly created LightType object

Exception | Condition |
---|---|
ArgumentException | The ElementId is the argument that is being validated The ElementId is not valid because it is not for a light element. |
ArgumentNullException | A non-optional argument was null |