Solid |
Splits a solid geometry into several separate solids.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Failed to split the solid geometry. |

If no splitting is done, a copy of the input solid will be returned in the output array.