Create Method (Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean)


Wall Create(Document, Curve, Element Id, Element Id, Double, Double, Boolean, Boolean) Method

Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Wall Create(
	Document document,
	Curve curve,
	ElementId wallTypeId,
	ElementId levelId,
	double height,
	double offset,
	bool flip,
	bool structural
)

Parameters

document Document
The document in which the new wall is created.
curve Curve
A curve representing the base line of the wall.
wallTypeId ElementId
Id of the wall type to be used by the new wall instead of the default type.
levelId ElementId
Id of the level on which the wall is to be placed.
height Double
The height of the wall other than the default height.
offset Double
Modifies the wall's Base Offset parameter to determine its vertical placement.
flip Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural Boolean
If set, specifies that the wall is structural in nature.

Return Value

Wall
If successful a new wall object within the project.
Exceptions
Exception Condition
ArgumentException The curve argument is not valid for wall creation.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The given value for height must be greater than 0 and no more than 30000 feet. -or- The given value for offset must be no more than 30000 feet in absolute value.
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also