SheetDuplicateOption Enumeration


Sheet Duplicate Option Enumeration

Options for duplicating sheets

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum SheetDuplicateOption
Members
Member name Value Description
DuplicateEmptySheet 0 Duplicate the sheet, only copy its title block.
DuplicateSheetWithDetailing 1 Duplicate the sheet, copy the title block and details.
DuplicateSheetWithViewsAndDetailing 3 Duplicate the sheet. Copy its title block, details, viewports, and duplicate its contained views with detailing. The newly created sheet will reference the newly duplicated views.
DuplicateSheetWithViewsAsDependent 4 Duplicate the sheet. Copy its title block, details, viewports, and duplicate its contained views as dependent. The newly created sheet will reference the newly duplicated dependent views.
DuplicateSheetWithViewsOnly 2 Duplicate the sheet. Copy its title block, details, viewports and contained views. The newly created sheet will reference the newly duplicated views.
See Also