GetMaterialGaugeByGUID Method


Fabrication Configuration Get Material Gauge By GUID Method

Gets the material gauge identifier by its GUID and material identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int GetMaterialGaugeByGUID(
	Guid gaugeGUID,
	int materialId
)

Parameters

gaugeGUID Guid
The material gauge GUID.
materialId Int32
The material identifier. The same material gauge GUID could have different material gauge identifiers for different materials.

Return Value

Int32
The gauge identifier. Returns 0 if not found.
See Also