Document Make |
This method encapsulates the process of creating transient elements in the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- maker ITransientElementMaker
- An instance of a class that implements the ITransientElementMaker interface. The maker will be called to create element(s) which would become transient.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This Document has an open editing transaction and is accepting changes. -or- This Document is read-only: It cannot be modified. |

The method establishes a context within which transient elements will be created and then invokes the given maker object to create the elements. For more information refer to the IsTransient method.