AddSharedParameterAsOverride Method


Rebar Container Parameter Manager Add Shared Parameter As Override Method

Adds a shared parameter as one of the parameter overrides stored by this Rebar Container element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void AddSharedParameterAsOverride(
	ElementId paramId
)

Parameters

paramId ElementId
The id of the shared parameter element
Exceptions
Exception Condition
ArgumentException paramId is not a valid Element identifier. -or- paramId is not the id of a shared parameter in the current document, or its name was already used by another shared parameter of the element. -or- paramId is already a Rebar Container parameter
ArgumentNullException A non-optional argument was null
See Also