TextPosition Property


Dimension Segment Text Position Property

The position of the dimension text's drag point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public XYZ TextPosition { get; set; }

Property Value

XYZ
Exceptions
Exception Condition
ApplicationException Thrown when the dimension text is unavailable.
InvalidOperationException Thrown when:
  • The dimension text is a SpotElevation
  • When using equality formula.
  • When dimension style is ordinate.
.
Remarks

This property is not applicable to all dimensions. For example, it is not available for spot dimensions, dimensions using equality formula, and when dimension style is ordinate.

If the position is not applicable, this property returns NULL and will not allow setting a value.

See Also