Ribbon |
This class is the base class of PushButton and PulldownButton.

System Object
Autodesk.Revit.UI RibbonItem
Autodesk.Revit.UI RibbonButton
Autodesk.Revit.UI PulldownButton
Autodesk.Revit.UI PushButton
Autodesk.Revit.UI RibbonItem
Autodesk.Revit.UI RibbonButton
Autodesk.Revit.UI PulldownButton
Autodesk.Revit.UI PushButton
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The RibbonButton type exposes the following members.

Name | Description | |
---|---|---|
![]() | Image | The image of the button. |
![]() | IsEnabledByContext | Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context. |
![]() | LargeImage | The large image shown on the button. |

Name | Description | |
---|---|---|