AddResolutionType Method


Failure Definition Add Resolution Type Method

Adds a type of possible resolution for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FailureDefinition AddResolutionType(
	FailureResolutionType type,
	string caption,
	Type classOfResolution
)

Parameters

type FailureResolutionType
Type of the resolution to add. The type of resolution can be used only once for the FailureDefinition.
caption String
A simple description of the resolution.
classOfResolution Type
The runtime class of the resolution. Used to ensure that the actual FailureResoution object added to the instance of FailureMessage belongs to an applicable class.

Return Value

FailureDefinition
The FailureDefinition.
Exceptions
Exception Condition
ArgumentException The type has already been added as a resolution to the FailureDefinition. -or- The input classOfResolution is not a subclass of FailureResolution.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
In order to inform Revit what failure resolutions can be possibly used with a given failure, a FailureDefinition must contain a full list of resolution types applicable to the failure, including user-visible caption and runtime class of the resolution. The number of resolutions is not limited. The first added resolution becomes the default resolution.
See Also