DuctSystemType Enumeration


Duct System Type Enumeration

An enumerated type listing all the possible duct system types for a connector object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum DuctSystemType
Members
Member name Value Description
ExhaustAir 3 Duct System Type is ExhaustAir.
Fitting 28 Duct System Type is Fitting.
Global 29 Duct System Type is Global.
OtherAir 4 Duct System Type is OtherAir.
ReturnAir 2 Duct System Type is ReturnAir.
SupplyAir 1 Duct System Type is SupplyAir.
UndefinedSystemType 0 Undefined system type.
See Also