NewFootPrintRoof Method


Document New Foot Print Roof Method

Creates a new FootPrintRoof element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public FootPrintRoof NewFootPrintRoof(
	CurveArray footPrint,
	Level level,
	RoofType roofType,
	out ModelCurveArray footPrintToModelCurvesMapping
)

Parameters

footPrint CurveArray
The footprint of the FootPrintRoof.
level Level
The level of the FootPrintRoof.
roofType RoofType
Type of the FootPrintRoof.
footPrintToModelCurvesMapping ModelCurveArray
An array of Model Curves corresponding to the set of Curves input in the footPrint. By knowing which Model Curve was created by each footPrint curve, you can set properties like SlopeAngle for each curve.

Return Value

FootPrintRoof
Exceptions
Exception Condition
ArgumentException Thrown if the level does not exist in the given document.
ArgumentException Thrown if the roof type does not exist in the given document.
Remarks
This method will regenerate the document even in manual regeneration mode.
See Also