Autodesk.Revit.UI.Selection Namespace


Autodesk. Revit. UI. Selection Namespace

Classes
Class Description
Public class PickedBox A class that contains two XYZ points representing the pick box on the screen.
Public class SelectableInViewFilter A filter that passes elements that are selectable in the given view.
Public class Code example Selection Contains the current user selection of elements within the project.
Interfaces
Interface Description
Public interface Code example ISelectionFilter An interface that provides the ability to filter objects during a selection operation.
Enumerations
Enumeration Description
Public enumeration ObjectSnapTypes This enumerated type contains object snap types allowed to be set during PickPoint operations.
Public enumeration ObjectType This enumerated type contains object types allowed to be selected during selection operations.
Public enumeration PickBoxStyle The enum that controls the style of the pick box.