External |
Supports the creation of new shared parameters definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ExternalDefinitions type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsEmpty | Identifies if the definitions collection is empty. (Inherited from Definitions ) |
![]() | Item | Retrieves a definition by a given name. (Inherited from Definitions ) |
![]() | Size | The number of definitions in the collection. (Inherited from Definitions ) |

Name | Description | |
---|---|---|
![]() | Contains | Tests for the existence of a definition within the set. (Inherited from Definitions ) |
![]() | Create | Creates a new parameter definition using specified options. (Inherited from Definitions ) |
![]() | Dispose | (Inherited from Definitions ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Definitions ) |
![]() | GetEnumerator | Retrieves an enumerator to the collection. (Inherited from Definitions ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |